GmTruckHQ is the resource on GM Trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim
Home   Forum   Chat   Register   Today's Posts   Search  

GMTruckHQ is the premier GM Truck Site on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Go Back   GmTruckHQ > Tech Discussions > Diagnostic Trouble Codes (DTCs)

service 4WD and service engine lights


Reply
 
Thread Tools Display Modes
Old 10-01-2014, 11:57 AM   #1
Sailcatt's Avatar
Send PM    Add to friends
Join Date: Sep 2014
 
  Sailcatt is offline    
Sailcatt
Junior Member

I have a 2000 Blazer V6 vortex engine and often the service 4WD light comes on when i start and often it doesnt, and once the service engine light came on and i checked the code P0300 was the code it was a misfire, but then the light went out and sometimes it sputters and sometimes it doesnt, does anyone know why and how do i fix these from coming back on

Reply With Quote
Old 10-02-2014, 01:15 AM   #2
montec's Avatar
Send PM    Add to friends
Join Date: May 2009
 
  montec is offline    
montec
Admin Team

Quote:
Originally Posted by Sailcatt View Post
I have a 2000 Blazer V6 vortex engine and often the service 4WD light comes on when i start and often it doesnt, and once the service engine light came on and i checked the code P0300 was the code it was a misfire, but then the light went out and sometimes it sputters and sometimes it doesnt, does anyone know why and how do i fix these from coming back on
well service 4wd could be a host of issues, does your 4wd work? will it switch between 2hi, 4hi and 4low? as for the random misfire have you don a tuneup yet?

_____________________________________________
1979 Monte Carlo with a 400hp+ 350ci.
1983 T10 w/2.8L getting parked till can restore and put a v8 in
1994 Blazer 4dr with the CPI(FOR SALE)
1995 Blazer 4Dr 4X4(FOR SALE)
2002 Trailblazer LT
2007 Envoy Denali

Independent AmsOil Dealer

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Old 10-02-2014, 01:53 AM   #3
Sailcatt's Avatar
Send PM    Add to friends
Join Date: Sep 2014
 
  Sailcatt is offline    
Sailcatt
Junior Member

Yes the 4WD works fine I checked it switches between 2wd 4wd hi and low, and no i have not done a tune up i just bought it about 6 months ago.

Reply With Quote
Old 10-03-2014, 01:29 AM   #4
montec's Avatar
Send PM    Add to friends
Join Date: May 2009
 
  montec is offline    
montec
Admin Team

Quote:
Originally Posted by Sailcatt View Post
Yes the 4WD works fine I checked it switches between 2wd 4wd hi and low, and no i have not done a tune up i just bought it about 6 months ago.
Get a Tune up, new plugs, wires, cap, rotor. Heck even get a new fuel filter while your at it. They are not difficult. Have fun, and welcome to the Forum.

_____________________________________________
1979 Monte Carlo with a 400hp+ 350ci.
1983 T10 w/2.8L getting parked till can restore and put a v8 in
1994 Blazer 4dr with the CPI(FOR SALE)
1995 Blazer 4Dr 4X4(FOR SALE)
2002 Trailblazer LT
2007 Envoy Denali

Independent AmsOil Dealer

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Old 10-04-2014, 03:11 PM   #5
Sailcatt's Avatar
Send PM    Add to friends
Join Date: Sep 2014
 
  Sailcatt is offline    
Sailcatt
Junior Member

will do, ty for the reply, and ty im enjoying reading and getting good feedback

Reply With Quote
Reply

Bookmarks


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


 


Vin Decoder Info